Error installing SEN4CAP

Dear SEN4CAP forum,
I ran into an error when installing the SEN4CAP distribution, i have this error both in v1.2 as in v2.0.

The error I get is "No sen2agri-services zip archive provided in ../sen2agri-service"

The script searches for a .zip file in …/sen2agri-services here:

if [ -f ../sen2agri-services/sen2agri-services*.zip ]; then
    zipArchive=$(ls -at ../sen2agri-services/sen2agri-services*.zip| head -n 1)
    if [ -f "../sen2agri-services/${SERVICES_ARCHIVE}" ]; then
        zipArchive=$(ls -at "../sen2agri-services/${SERVICES_ARCHIVE}" | head -n 1)

But in the folder structure its named 20210205_Sen4CAPDistribution_2.0\Sen4CAPDistribution\sen2agri-services\

How should i fix this?

Thanks in advance,
Thijs Oosterhuis

Dear Thijs,

Actually, the code you mentioned is a fallback for the case when the services archive is not defined in the file Sen4CAPDistribution\install_script\config\install_config.conf.
Could you please check that you have this file in the installation package?
Also, in this file, should be correctly defined the following lines:


Best regards,

Dear Cudrouiu,
Thanks a lot for your reply! I do seem to have that file, with the parameters specified (see screenshot).
Still I run into that error. Maybe I should sed the specific line which looks for sen2agri-services*.zip? Any other tips?


Dear Thijs,

Do you run the installation script from the install_script directory or from another path?
Did you try, before running it:

cd Sen4CAPDistribution/install_script/


Hey Cudroiu,
Thanks again for your quick reply. I maybe should have mentioned that I run the from a Dockerfile, so the paths inside that shell script might be different. Usually a Dockerfile requires the complete paths. I’ll try to run it from the location you mentioned.

Do you have any experiene with running it from inside a Dockerfile?


As an update, running this before fixes the issue, might be an idea for other users as well:
RUN sed ‘3 {s/^/cd /\home/\Sen4CAPDistribution/\install_script/}’ /home/Sen4CAPDistribution/install_script/ > /home/Sen4CAPDistribution/install_script/newFile
RUN mv /home/Sen4CAPDistribution/install_script/newFile /home/Sen4CAPDistribution/install_script/