Error of L2-S1 Pre-Processor

Hello sen4cap,

I have deployed sen4cap and it’s working well until when it started creating L2A processor. it downloaded Sentinel 1 data as well and wonder why I am getting below error.

Error on Calibration 1-1

Error executing step 1 (Calibration) [codes=[-255]]: [{gpt,-c,256M,-q,8,/mnt/archive/s1_preprocessing_work_dir/SEN4CAP_L2A_S3_V20191231T225931_20191225T230035_VH_164/s1_step_1_1.xml,/mnt/archive/dwn_def/s1/default/sugarcane/S1B_IW_SLC__1SDV_20191231T225931_20191231T225959_019615_025126_4C4F.SAFE,/mnt/archive/dwn_def/s1/default/sugarcane/S1A_IW_SLC__1SDV_20191225T230035_20191225T230102_030511_037E72_061B.SAFE}]

Thanks,
Henry

Hello Henry,

What happens when you open a console and execute the following:

gpt -c 256M -q 8 /mnt/archive/s1_preprocessing_work_dir/SEN4CAP_L2A_S3_V20191231T225931_20191225T230035_VH_164/s1_step_1_1.xml /mnt/archive/dwn_def/s1/default/sugarcane/S1B_IW_SLC__1SDV_20191231T225931_20191231T225959_019615_025126_4C4F.SAFE /mnt/archive/dwn_def/s1/default/sugarcane/S1A_IW_SLC__1SDV_20191225T230035_20191225T230102_030511_037E72_061B.SAFE ?

The above is a single command line (without the question mark).

Hello Kraftek,

Thank you for getting back to me. gpt is not working in my console. it’s a part of sen4cap services?

Regards,
Henry

Hello Henry,

No, it is part of SNAP, that should be installed by the installer of the Sen4CAP system. You should find it in /opt/snap/bin. Isn’t it there?

Cosmin.

Hello Cosmin,

That’s good to know. Nope. it’s not there. SNAP is not installed yet. Hope it will work fine after installation of SNAP.

Thanks,
Henry

Hello Cosmin,

I have installed SNAP. Here is the result after executing the command.

INFO: org.esa.snap.core.gpf.operators.tooladapter.ToolAdapterIO: Initializing external tool adapters
SEVERE: org.esa.s2tbx.dataio.gdal.activator.GDALDistributionInstaller: The environment variable LD_LIBRARY_PATH is not set. It must contain the current folder ‘.’.
INFO: org.esa.snap.core.util.EngineVersionCheckActivator: Please check regularly for new updates for the best SNAP experience.

Error: /mnt/archive/s1_preprocessing_work_dir/SEN4CAP_L2A_S3_V20191231T225931_20191225T230035_VH_164/s1_step_1_1.xml (No such file or directory)

Regards,
Henry

Hello Cosmin,

Error is still there even after SNAP installation. I have restarted sen4cap service as well. no luck yet. any tips? thanks.

here is output.log i found under the s1_preprocessing_work_dir folder. hope it helps to find the root cause. let me know if u need further information.

020-03-31 17:09:51 - FINE - Master: S1B_IW_SLC__1SDV_20190306T225923_20190306T225951_015240_01C839_270D.SAFE, slave: S1A_IW_SLC__1SDV_20190312T230001_20190312T230029_026311_02F0FC_243F.SAFE
2020-03-31 17:09:52 - FINE - Executing step 1 (Calibration): [{gpt,-c,256M,-q,8,/mnt/archive/s1_preprocessing_work_dir/SEN4CAP_L2A_S3_V20190306T225923_20190312T230001_VH_164/s1_step_1_1.xml,/mnt/archive/dwn_def/s1/default/sugarcane/S1B_IW_SLC__1SDV_20190306T225923_20190306T225951_015240_01C839_270D.SAFE,/mnt/archive/dwn_def/s1/default/sugarcane/S1A_IW_SLC__1SDV_20190312T230001_20190312T230029_026311_02F0FC_243F.SAFE}]
2020-03-31 17:09:52 - SEVERE - Error executing step 1 (Calibration) [codes=[-255]]: [{gpt,-c,256M,-q,8,/mnt/archive/s1_preprocessing_work_dir/SEN4CAP_L2A_S3_V20190306T225923_20190312T230001_VH_164/s1_step_1_1.xml,/mnt/archive/dwn_def/s1/default/sugarcane/S1B_IW_SLC__1SDV_20190306T225923_20190306T225951_015240_01C839_270D.SAFE,/mnt/archive/dwn_def/s1/default/sugarcane/S1A_IW_SLC__1SDV_20190312T230001_20190312T230029_026311_02F0FC_243F.SAFE}]
2020-03-31 17:09:52 - FINE - Step 1 (Calibration) completed in 00m00s
2020-03-31 17:09:52 - FINE - Products {SEN4CAP_L2A_S3_V20190306T225923_20190312T230001_VH_164_S1_L2A_COHE,SEN4CAP_L2A_S3_V20190306T225923_20190312T230001_VH_164_S1_L2A_AMP} failed after 00m00s

Henry

same issue here! I installed Sen4cap 1.2 on a VM with CentOS 7. The SNAP is in the opt/ folder.
The following issue error occurss:
Error executing step 1 (Calibration) [codes=[-255]]: [{gpt,-c,256M,-q,8,/mnt/archive/nb/l2a-s1/SEN4CAP_L2A_S1_V20200723T222005_20200804T222005_VH_091/s1_step_1_1.xml,/mnt/archive/dwn_def/s1/default/nb/S1A_IW_SLC__1SDV_20200723T222005_20200723T222032_033588_03E482_EB2C.SAFE,/mnt/archive/dwn_def/s1/default/nb/S1A_IW_SLC__1SDV_20200804T222005_20200804T222032_033763_03E9DC_FD97.SAFE}]

Besides this, it does not process S2 or L8 data as well. already installed the whole system twice with the latest data on the installation page.

Hello,

Is this a general error for all the products or only for some of them?
Also, did you installed SNAP manually or was it installed from the Sen4CAP installation package?
If you installed it manually, you might need to change the content of the file /opt/snap/bin/gpt.vmoptions with the content of the file gpt.vmoptions located in the installation package in Sen4CAPDistribution/install_script/config. Also make sure that if /usr/local/bin/gpt exists, otherwise create it using

sudo ln -s /opt/snap/bin/gpt /usr/local/bin/gpt

Other reasons why this step might fail are:

  • there is not enough available memory in the system. How much memory has your machine? Are also other processes running there that might consume huge amounts of memory?
  • During the S1 pre-processing SNAP is trying to download some orbit and DEM files from the step.esa.int or other sites. These steps might fail if the site(s) where these sites are not available. In this case, you might be forced to reset the status of the failed S1 products from 6 to 2 into the downloader_history table.

Concerning the S2 pre-processing:

  • can you provide more detail?
  • Are the S2 products downloaded OK?
  • What are these products statuses in the downloader_history table?
  • If you cleanup the l1_tile_history table and reset the status of the S2 products in the downloader_history from 6 to 2 (assuming they are with status 6), could you please provide the log messages given by the sen2agri-demmaccs service?
  • Can you check also this http://esa-sen4cap.org/faq#n55 ?

Best regards,
Cosmin

Hi Cosmin,
Thanks for the elaborate reply. I will try to answer the questions below:
It was a general error. I installed the previous version 1.1 instead and this solved the issue for me.
System: VMware OS7.6 32gb RAM, 1 TB ssd. (small research site for testing)
Still, it does not process S2 and L8 data. The products are downloaded fine and they show up in the mnt/archive/down…

Capture of S2 statistics: I’m not a developer so i’m not sure ow th cleanup the L1_tile_history and provide answers to the following question. sorry for that.
sen2agri-demmaccs

I looked at FAQ 55 and i try to run the commands: this it wat it returned:
[root@localhost ~]# psql -U admin psql -c “select * from config where key = ‘demmaccs.maccs-launcher’”
psql: error: could not connect to server: FATAL: database “psql” does not exist
[root@localhost ~]#
Did i run the code correctly and could this be the reason for processing failure?

Hello,
It seems that there was a small error on the FAQ page (corrected now).
The command you should run are actually:

psql -U admin sen4cap -c “select * from config where key = ‘demmaccs.maccs-launcher’”
psql -U admin sen4cap -c “select * from config where key = ‘demmaccs.gips-path’”

Please let me know.

Best regards,
Cosmin

P.S. Please pay attention to quotes as the forum editor tends to change them so you better type them manually rather than copy/paste commands from here. Alternatively, you can get the commands again from the FAQ page http://esa-sen4cap.org/faq#n55.