Error when running the dockerfile

Dear all,
Thanks for the new update of sen4cap. Great addition to make the services run from a docker container. However, when building the container I ran into an issue with the Dockerfile.

It seems a package is missing. What is the proposed work around?

This is my error:

—> Package libcurl-devel.x86_64 0:7.29.0-59.el7_9.1 will be an update
epel/x86_64/filelists_db | 12 MB 00:00:00
base/7/x86_64/filelists_db | 7.2 MB 00:00:00
updates/7/x86_64/filelists_db | 3.4 MB 00:00:00 [Errno 14] HTTPS Error 404 - Not Found
Trying other mirror.

One of the configured repositories failed (PostgreSQL 9.4 for RHEL/CentOS 7 - x86_64),
and yum doesn’t have enough cached data to continue. At this point the only
safe thing yum can do is fail. There are a few ways to work “fix” this:

 1. Contact the upstream for the repository and get them to fix the problem.

 2. Reconfigure the baseurl/etc. for the repository, to point to a working
    upstream. This is most often useful if you are using a newer
    distribution release than is supported by the repository (and the
    packages for the previous distribution release still work).

 3. Run the command with the repository temporarily disabled
        yum --disablerepo=pgdg94 ...

 4. Disable the repository permanently, so yum won't use it by default. Yum
    will then just ignore the repository until you permanently enable it
    again or use --enablerepo for temporary usage:

        yum-config-manager --disable pgdg94
        subscription-manager repos --disable=pgdg94

 5. Configure the failing repository to be skipped, if it is unavailable.
    Note that yum will try to contact the repo. when it runs most commands,
    so will have to try and fail each time (and thus. yum will be be much
    slower). If it is a very temporary problem though, this is often a nice

        yum-config-manager --save --setopt=pgdg94.skip_if_unavailable=true

failure: repodata/4ec20523cef83445c709daa1ec4f1de9e4f3ff0a8bc3484f120bb4413b7756ed-filelists.sqlite.bz2 from pgdg94: [Errno 256] No more mirrors to try. [Errno 14] HTTPS Error 404 - Not Found

Dear all, I fixed this with changing the line "yum -y install boost-devel " to “yum --disablerepo=pgdg94 -y install boost-devel” but im curious on the official workaround from SEN4CAP.

Second error I ran into when running the line “gem install fpm” is this one:

ERROR: Error installing fpm: git requires Ruby version >= 2.3.