L2-S1 processor: no coherence generation

Dear Sen4CAP team,

I am using Sen4CAP version 1.2. The L2-S1 processor produces the amplitude files for VV and VH polarizations, but not the coherence. Yet in the config table, the key “processor.l2s1.compute.coherence” is set to true.

Here is an extract of one of the output log files for S1 L2:

2020-09-03 23:57:00 - FINE - Step 6 (Amplitude Terrain Correction) completed in 02m04s
2020-09-03 23:57:00 - FINE - Step Coherence Deburst will be skipped (coherence flag reset)
2020-09-03 23:57:00 - FINE - Step Coherence Merge will be skipped (coherence flag reset)
2020-09-03 23:57:01 - FINE - Step Coherence Terrain Correction will be skipped (coherence flag reset)
2020-09-03 23:57:34 - FINE - Product {SEN4CAP_L2A_S8_V20191210T003730_20191222T003729_VV_107_AMP} completed after 19m05s

Could you help me finding why the coherence step is skipped?

Also, I’ve noticed in the config table that processor.l2s1.projection is set to ETRS89 / LAEA Europe by default. My study site is in the US. Should I change the projection system for this site?

Thanks in advance for you help.


Any clues on why the coherence is not produced while the amplitude is?

Even when I restart the services, I get the following message for each acquisition to process:
DEBUG [DefaultQuartzScheduler_Worker-3] o.e.s.p.Sentinel1L2Processor - **Sentinel-1 Level2 processor received flags: AMPLITUDE=true, COHERENCE=false, OVERWRITE=false**

I’ve noticed that the Sentinel-2 pre-processing uses by default S1B products as master. However, in my study site, I only have S1A acquisitions. So I changed the processor.l2s1.master to S1A in the config table, but even after restarting the sen2agri services, I still get the same message and the coherence is not produced.

How can I change the coherence flag to true? Has anyone encountered the same issue before?

Thanks in advance for the help!

Best regards