New Job Error

Hello SEN4CAP team,

We are new users of Sen4Cap and we have added a new job T-Rex Updater but it is not running. The status is submitted and start type triggered.

The Job Output is the following:

Step Name:
TRexUpdater

Command:
t-rex-genconfig.py docker run --rm -u 1000:1000 --group-add 994 -v /var/run/docker.sock:/var/run/docker.sock -v /var/lib/t-rex:/var/lib/t-rex -v /mnt/archive/orchestrator_temp:/mnt/archive/orchestrator_temp -v /mnt/archive:/mnt/archive -v /etc/sen2agri:/etc/sen2agri sen4cap/data-preparation:0.1 t-rex-genconfig.py --restart-container docker_t-rex_1 /var/lib/t-rex/t-rex.toml

Output:
null

Errors:
null

Do you have any idea why we have this error?

Thank you,
Sofia

Dear Sofia,

The issue might be that the sen2agri-executor is not started.
You can try restarting the following services:

sudo systemctl restart sen2agri-scheduler sen2agri-orchestrator sen2agri-executor

Then try again running your job.
Nevertheless, please note that the T-Rex Updater is not a job intended to be run manually by the users (probably we will remove this option in the future to avoid confusions) but is run automatically by the system when a new vector product is ingested into the system. On the other hand, it doesn’t harm either if you run it manually :wink: .

Best regards,
Cosmin

Hi,

I have a similar error. I tried restarting the services as mentioned by Cosmin, but with the same result. What is also interesting is that I managed to upload the LPIS declarations and LUT successfully, but they are not available in the product list. If I look in the database the products are available.

Any ideas?
Best regards,
Marcel




I should also mention that uploading the declaration data using the graphical interface results in an error. I thought is was because of a mismatch between the cropcode from the LUT and the cropcode from the declaration data but both are integers.