Output of running L4A

Hello everyone,

After I’ve tried to run the L4A manually, through the sen2agri-service user, it does output all files for accuracy/predictions and alike, but whenever I try to run it using “both” products sentinel 1, and sentinel 2, it always fails at the point of:
IOError: [Errno 2] No such file or directory: ‘/mnt/archive/orchestrator_temp/s4c_l4a/1977/14176-s4c-crop-type/features/optical-features.ipc’

Nevertheless, if I run the same command using the mode of “S1-only” or “S2-only”, it never comes to this problem. I know optical-features correspond to the S2 products, but at least I would have expected that it would fail on the “S2-only” mode

Any help would be greatly appreciated!


Hello. Can you please post the output of sudo docker images and sudo docker run --rm -it sen4cap/processors:2.0.0 cat /usr/bin/crop-type-wrapper.py?

Hey Inicola. I did not run the command through the platform/docker, I went to the jobId pertaining to the L4A job process and first run the extract-parcels.py with the list of the desired products (and subsequently checked that the output csv’s had products both in radar and optical), and then went on to run manually the crop-type-wrapper.py deleting the lines pertaining to the docker (crop-type-wrapper.py docker run --rm -u 1000:1000 -v /mnt/archive/orchestrator_temp/s4c_l4a:/mnt/archive/orchestrator_temp/s4c_l4a -v /mnt/archive:/mnt/archive sen4cap/processors:2.0.0).

Nevertheless, to also answer your question, I ran the command and these are the results I got (deleted the SIZE column information)
docker.io/osgeo/gdal latest ae8f1fd9b942 13 days ago docker.io/dpage/pgadmin4 latest 636dbafc286f 2 weeks ago
docker.io/sen4cap/processors 2.0.0 dd02281f3c9f 2 months ago
docker.io/lnicola/sen2agri-l2a-processors latest d577b6a46be8 2 months ago
docker.io/lnicola/sen2agri-dem latest 8bb573b3eb9f 2 months ago
docker.io/postgis/postgis 11-3.0 1dd39e8e9c42 3 months ago
docker.io/lnicola/maja 3.2.2-centos-7 7f5de4615f74 4 months ago

The output of the second one is attached in the file below
crop-type-wrapper.txt (13.1 KB)