Problems with login via website interface after update to version 3.0

Today I tried to update our sen4cap installation from version 2 to version 3.

With version 2 we also had our problems and were unfortunately unsuccessful in processing higher-level products (processing simply stopped after the L2-S1 processor), which is why we continued to work with our own algorithms in the past season.

After I attended your presentation of the new version on Tuesday and saw that you have also done something in the direction of user-friendliness (new web interface from which all configuration of a season can be made, etc.), I wanted to make a new attempt.

Now I have carried out the update. At first glance everything went through successfully, there were no error messages or something similar.

However, after the update it was no longer possible for me to log into the system via the web interface.

Our sen4cap installation runs on a cloud contingent on (german Copernicus Data and Exploitation Platform, similar to creodias).

Before the update, I was able to interact with sen4cap via the web browser using our.public.ip.address/login.php.

After the update, the address our.public.ip.address/ui/login.html was not known.

The Apache web server told me to put my webpages in the /var/www/html/ folder if necessary.

After I found the new login.html mentioned in the sen4cap-manual under /usr/share/sen2agri/sen2agri-services/static/, I created a symbolic link to it in /var/www/html/ui/.

Now I can get to the login page of our sen4cap installation via our.public.ip.address/ui/login.html, but I don’t get any response when I try to login with my old credentials. Also the default user “sen4cap” (password: sen4cap) does not work. After clicking on the “login” button nothing happens.

Any hints/tips?

Shouldn’t the web interface have been automatically accessible under the mentioned URL after the update?

Did my linking under /var/www/html/ make any sense or am I completely wrong?

Why are the buttons on the login.html out of function? Does this have something to do with this linking, a faulty Apache configuration, missing libraries or what else could it be?

Hi, when I ran into the same problem I resolved it by specifying port in the address. Try


Without port I still end up on the default apache page, with it all works fine, no need to create symbolic links.


Thanks for the quick feedback @adam.knaze !

Yes, I had tried that with the specification of the port first as described in the manual, unfortunately without success.

Specifying the port, after a while I get an error message due to a network timeout. Without it I am at least able to get to the login page.

I also made sure that the port is open in the server’s firewall. This is also the case. Otherwise I would have had the same problems with version 2.0, right?

As you can see, I am not a network specialist. I just want to do my remote sensing and try out this promising toolbox. :wink:

But I always like to learn. So best thanks for all further hints!

Ok, so I did some more research and had netstat show me which processes are listening on which ports.

If I understand it correctly, the services relevant to sen2agri do listen on the correct ports 80 (httpd) and 8080 (java) as well as 8082 (sen2agri-http-) and 8083 (sen2agri-orche), of which 80 and 8080 I also have open in the firewall. Is it correct to have port 80 and 8080 open? Or is port 80 alone sufficient? Or must 8082 and 8083 also be open?

However, I noticed that netstat shows me that these are all running over the tcp6 protocol. However, we only have a public IPv4 address via code-de to access our machine.

Couldn’t this be the problem and if so, does anyone know where and how I can get the sen4cap/agri services to listen for access over IPv4 as well?

Only the port 8080 is needed by the Sen4CAP 3.0 to be opened and the port 80 is no longer used by Sen4CAP.
Anyway, my assumption is that opening the port 8080 only in the firewall on your machine might not be enough. You should check also in the administration page of your machine from CODE-DE (I assume you have access to such a page) and see if the port 8080 is also open from there.
Please note that there is no need to open the other ports 8082 or 8083 as these are used only internally by the Sen4CAP services.


Hello @cudroiu

Thank you for your advice.

You were right. Via my OpenStack dashboard for CODE-DE I could see that only port 80 was open so far. I have now also allowed incoming IPv4 connections through port 8080.

Unfortunately, that doesn’t help me either. The login button still seems to be out of function.

Also, the address our.public.ip.address/ui/login.html is still only found via my symbolic link in /var/www/html/.

Besides that the Apache Web Server seems to be configured correctly, right? Under our.public.ip.adress I reach the default Apache HTTP server page.

The ports should be configured correctly now too, right?

Do you have an idea what else could be the problem?

Could it have anything to do with the sen4cap services, or is it definitely a pure network configuration problem? (In that case I don’t want to bother you here any further and maybe try next week a noob-like but time-consuming reinstallation of the whole system -.- )

I assume there is no chance to provide me access to that machine. It would work faster and we could quickly check what is happening on that machine. If possible, you can write me in private either on forum or send me an email on
Normally, in 3.0 there are not needed any symlinks or other operations for making the site work. The Apache HTTP is no longer used by the site as now the site is delivered via an internal tomcat embedded in the sen4cap services and listening on port 8080. The website in 3.0 (which is pure html and javascript) is completely embedded also in the sen4cap services and the old site from /var/www/html (which was in 2.0 and using php) is no longer installed.
So you should try :

  • Remove any symlinks from /var/www/html to probably /usr/share/sen2agri/sen2agri-services/static/ …
  • Check that services are started and running on port 8080 (or whatever configured in You can try restarting them and check the initial ports that they successfully opened the port (maybe somebody else is listening on that port and they really cannot open it).
  • Check the port 8080 that is really accessible from outside
  • If all of the above are performed, the site should be accessible via http://<your_ip>:8080/ui/login.html

Best regards,

Thanks for your detailed tips @cudroiu!

It works now!

Just don’t ask me why -.-

I was just about to implement your steps: delete symlink, check running services, restart them and the system, check accessibility of port 8080…

Last week I was able to test the ports with “telnet <our_ip> port”. Today this doesn’t work anymore: “telnet: Unable to connect to remote host: Network is unreachable”.

Instead I now suddenly get into the system via http://<our_ip>:8080/ui/login.html.

On the one hand it’s nice that it finally works, on the other hand it’s unsatisfying that I can’t understand why or what the problem was.

Anyway, thanks for your detailed help and the offer to have a closer look at our system.

Now I can finally test if we can get beyond the L2-S1 preprocessors with version 3.0.