Sen2Agri Configurator


I recently installed the Sen4cap SW and I wanted to change some parameters through the configurator. However I see this error message


Can you please suggest any resolution?

Thank you,

Can you please help with this issue, the new version did not solve the problem. thank you,

Dear Andrea,

You can try the commands :

psql -U admin sen4cap -c “update config_metadata set key = ‘processor.s4c_l4b.default_config_path’ where key = ‘processor.s4c_l4b.config_path’;”

psql -U admin sen4cap -c “update config_metadata set key = ‘processor.s4c_l4c.default_config_path’ where key = ‘processor.s4c_l4c.config_path’;”

Please let me know.

Best regards,

Hi Cosmin,

after correcting the two entry in the database a different error message appears.

This time however the correct key is set in config_metadata, it appears a different key is set in config (see image)

shall I add the entry in config?

Why is this happening? is my installation correct?

Thank you

two years later I have the same error in the newest version. After running your two commands, I got this followi-up error:

It did solve the first two issues but I am still not able to open the configurator. Any thoughts?


I did a fresh install now and encountering the same issue here. Is there already any idea how this can be solved?

Best Martin!

Dear Martin,

To solve this you could try removing the entries corresponding to these items from the “config_metadata” table. Seems that during update they were only removed from the config table but not from the config_metadata.

psql -U admin sen4cap -c “delete from config_metadata where key = ‘executor.module.path.s4c-grassland-mowing-s1’”

And I think that you could also directly run also the command:

psql -U admin sen4cap -c “delete from config_metadata where key = ‘executor.module.path.s4c-grassland-mowing-s2’”

Please let me know if you encounter the error with other keys but normally you could run the commands above for them too (there is no danger as they do not exist anymore in the config table, the place where they have values). config_metadata contains only the description of the items in the config table and is used only by the configurator.

Best regards,

Thank you! I deleted the entries and now the configurator starts properly!

Best regards,